Updating your nim image

Posted by / 03-Feb-2020 08:55

Updating your nim image

If you have used the x CAT IBM HPC Integration support to initially install HPC software on your cluster nodes, you can apply product updates to your cluster in several different ways.

The method you choose will depend upon many factors: As with all product updates, you will need to be aware of any new operating system dependencies, any changes required to the product configuration, or any changes to operational procedures for administering or using the product.

You can either stop all the nodes and then update the existing OS image, or, you can create a new updated image to use to boot the nodes.

Stopping the nodes to do the updates means the nodes will be unusable for some period of time and there will be no easy way to return to the previous image if necessary.

Note: For Linux statelite clusters, a problem exists when updating the Load Leveler rpms(e.g. Currently, a new license rpm is shipped and must be installed and accepted before the other LL rpms will install correctly.

This will be fixed in future LL PTFs, so that customers will only need to accept the license when installing the base LL rpms.

In this case we create a new x CAT osimage definition with a new set of resources by running the x CAT mknimimage command with the source for the new resources.

Currently, the x CAT HPC integration does not support Load Leveler upgrades until a fix becomes available.This document describes some of the basic support that is provided for AIX nodes.XCAT provides support for distributing configuration files, updating software and running customization scripts on the cluster nodes.Use this method for updating your HPC software when there are extensive changes, you wish to test the changes on a small number of nodes first, you have a limited maintenance window or can do a rolling upgrade, or if you need to keep a copy of your existing image to revert back to if the updates fail.For Linux: For Linux statelite or stateless clusters, a problem exists when updating the Load Leveler rpms(e.g. Currently, a new license rpm is shipped and must be installed and accepted before the other LL rpms will install correctly.

updating your nim image-2updating your nim image-21updating your nim image-88

Once fixed, when LL is updated, no LL license rpm will be updated and customers will not need to accept the license a second time.

One thought on “updating your nim image”